Rwserver install in 10.1.2 developer suite

hye!
i'm using developer suite 10.1.2. and database 10.1.2, owb last version (i think it's release 1)
in forms...on a TLIST...i have 4 items:
-export to pdf message('1');
-export to excel message('2');
-export to xml message('3');
-export to... message('4'); THIS WORKS JUST FINE
now i want to replace message('1');
with :
BEGIN
rep_id := find_report_object('REPORT44');
SET_REPORT_OBJECT_PROPERTY(rep_id,REPORT_SERVER,'repserv');
SET_REPORT_OBJECT_PROPERTY(rep_id,report_desformat,'PDF');
SET_REPORT_OBJECT_PROPERTY(rep_id,report_execution_mode,runtime);
SET_REPORT_OBJECT_PROPERTY(rep_id,report_comm_mode,synchronous);
SET_REPORT_OBJECT_PROPERTY(rep_id,report_destype,screen);
v_rep := RUN_REPORT_OBJECT(rep_id);
rep_status := REPORT_OBJECT_STATUS(v_rep);
if rep_status = 'FINISHED'
then message('Report executed');
else message('Error! The Report can not be executed');
end if;
END;
PROCEDURE select_item_list (lista varchar2) IS
list_id item;
list_count number;
current_value VARCHAR2(50);
clicked_value VARCHAR2(50):= name_in(lista);
clicked_label VARCHAR2(80);
rep_id REPORT_OBJECT;
v_rep VARCHAR2(100);
rep_status VARCHAR2(20);
begin
list_id := find_item(lista);
if id_null(list_id) then
message('Nu a gasit id-ul item-ului!');
raise form_trigger_failure;
end if;
list_count := get_list_element_count(list_id);
for i in 1..list_count loop
current_value := get_list_element_value(list_id, i);
if clicked_value = current_value THEN
clicked_label := get_list_element_label(list_id, i);
exit;
end if;
end loop;
if current_value='0' then
BEGIN
rep_id := find_report_object('REPORT44');
SET_REPORT_OBJECT_PROPERTY(rep_id,REPORT_SERVER,'repserv');
SET_REPORT_OBJECT_PROPERTY(rep_id,report_desformat,'PDF');
SET_REPORT_OBJECT_PROPERTY(rep_id,report_execution_mode,runtime);
SET_REPORT_OBJECT_PROPERTY(rep_id,report_comm_mode,synchronous);
SET_REPORT_OBJECT_PROPERTY(rep_id,report_destype,screen);
v_rep := RUN_REPORT_OBJECT(rep_id);
rep_status := REPORT_OBJECT_STATUS(v_rep);
if rep_status = 'FINISHED'
then message('Report executed');
else message('Error! The Report can not be executed');
end if;
END;
elsif current_value='1' then message('ok1');
elsif current_value='2' then message('ok2');
elsif current_value='3' then message('ok3');
end if;
exception when others then message('Alte exceptii!');
raise form_trigger_failure;
end;
declare
list_activated varchar2(50) := :system.trigger_item;
begin
if list_activated = 'BLOCK21.LIST35' then
select_item_list ('BLOCK21.LIST35');
end if;
end;
now i' reading :
Oracle® Application Server Reports Services
Publishing Reports to the Web
10g Release 2 (10.1.2)
B14048-02
http://brom900lmlw5hb.pdcbr.rom:8889/reports/rwservlet/startserver
=> "javaw.exe - Entry point kguuseg could not be located in the dynamic link library oraclient10.dll"
cmd:
rwserver server=repserv batch=yes
=> "javaw.exe - Entry point kguuseg could not be located in the dynamic link library oraclient10.dll"
http://brom900lmlw5hb.pdcbr.rom:8889/reports/rwservlet/getserverinfo?server=repserv
=> REP-51002: Bind to Reports Server repserv failed
and when running the form i get
=>frm-41213: unable to connect to the Report server repserv
in programs-> developer suite home -> reports developer i have:
1.Oracle app server reports services:
-reports converter
-reports queue manager
etc.........
Do i need to install anything else? what to do to get de report run in forms???????
Advertisement
Reply

Hello,
have you installed the database 10.1.2 AFTER developer suite 10.1.2. ?
In this case, the problem may be the PATH
You can use a BAT file to set the PATH :
example:
title ODS 10.1.2
set ORACLE_HOME=e:\oracle\ods1012
set CLASSPATH=%ORACLE_HOME%\jlib\bigraphbean.jar;%ORACLE_HOME%\jlib\LW_PfjBean.jar;%ORACLE_HOME%\jlib\bigraphbean-nls.zip;%ORACLE_HOME%\reports\jlib\rwrun.jar
set PATH=e:\oracle\ods1012\bin;e:\oracle\ods1012\jdk\jre\bin;e:\oracle\ods1012\jdk\jre\bin\classic;e:\oracle\ods1012\jdk\jre\bin\classic;e:\oracle\ods1012\jlib;e:\oracle\ods1012\jdk\bin;c:\winnt;c:\winnt\system32
E:
cd \oracle\ods1012\bin
For the standalone OC4J , you can add a line:
set PATH=..
in the bat file startinst.bat
Regards