X201 Internal Speakers Stop Working

I am having a problem with the internal speakers on the X201.  Basically, the speakers just stop working.  I could be in the middle of playing a song and the speakers pop and then go out.  I have to reboot the system for them to work again.  Headphones still work despite the fact they go out.  
I am thinking this is a fault with the IO Assembly board, but am not sure..  I have reinstalled Win7 clean with updated drivers and still see the same problem.
Another interesting thing is I keep getting the disconnect/connect sound ( like you are plugging in a usb device ) at random times.  That always seems to correlate to the windows AUDIODG process.
Any ideas?
Advertisement
Reply

As you have already reinstalled the Operating System and drivers are also updated.
I suggest you to update the BIOS and check
http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mob​iles/6quj16us.exe
If then also the issue persist and your laptop is in warranty then you can contact the support center.
Country or Region
Language
Telephone number
Hours of operation
United States
English
1-800-426-7378 
Select "Option #1"
24 hours/day
7 days/week
Best Regards,
Tanuj
Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.
Follow @LenovoForums on Twitter!